Accueil / Actualités / Bukkit, CraftBukkit & Spigot 1.8 disponibles !

Bukkit, CraftBukkit & Spigot 1.8 disponibles !

Bukkit, CraftBukkit & Spigot 1.8 disponibles !
3.3(66.67%) 3 votes

Bonsoir tout le monde ! Cette petite news toute fraîche pour vous informer d’un évènement très important !

C’est enfin arrivé ! Après l’affaire Bukkit, personne ne savait vraiment à quoi s’en tenir, mais aujourd’hui c’est bel et bien arrivé, mes chers amis ! Bukkit, CraftBukkit et Spigot sont disponibles en 1.8 !
C’est ici que la nouvelle a été annoncée ce jour.
Vos serveurs 1.8 vont enfin pouvoir accueillir les centaines de plugins que vous chérissez et vous allez enfin pouvoir les mettre à jour !

Voici donc comment accéder à ce Graal tant convoité depuis des mois !

Ces premières versions sont disponibles pour Linux et Windows, pas encore pour Mac pour le moment.

Le processus d’installation ci-dessous est assez complexe.
Si vous avez une erreur concernant la variable JAVA_HOME,
je ne sais pas comment la régler.
Une installation plus simple arrivera certainement ces prochaines heures !

 

Prérequis Windows :

  • Vous aurez besoin du Java Development Kit :

JDK

  • Vous aurez également besoin de Git pour Windows :

Git

Prérequis Linux :

  • Pour les distributions type Debian / Ubuntu, tapez cette commande : sudo apt-get install git openjdk-7-jdk
  • Pour les distributions CentOS, celle-ci : sudo yum install git java-1.7.0-openjdk

 

Installation : (merci à Doums_ pour son tutoriel)

  1. Ouvrez votre terminal. Pour Windows, ouvrez simplement Git.
  2. Téléchargez BuildTools.jar : BuildTools
  3. Créez un dossier vide en le nommant comme bon vous semble et placez-y uniquement BuildTools.jar
  4. Dans menu démarrer, tous les programmes, dossier Git, lancez Git GUI
  5. Cliquez sur “Créer un nouveau dépôt”
  6. Sélectionnez le fameux dossier comportant BuildTools.jar
  7. Le logiciel s’est ouvert, cliquez sur l’onglet Dépôt de Git GUI puis sur Git Bash
  8. Une fenêtre de type cmd s’ouvre, c’est à ce moment qu’il ne vous reste plus qu’a rentrer la commande selon si le nom de votre dossier Program Files :
    • Sur Windows 32 bits, rendez-vous dans ce dossier via Git, puis tapez la commande suivante : JAVA_HOME=”C:\Program Files\Java\jdk1.8.0_25″ java -jar BuildTools.jar
    • Sur Windows 64 bits, rendez-vous dans ce dossier via Git, puis tapez la commande suivante : JAVA_HOME=”C:\Program Files (x86)\Java\jdk1.8.0_25″ java -jar BuildTools.jar
    • Sur Linux, celle-ci : java -jar BuildTools.jar
  9. Voila, après des lignes et des lignes défilent pendant une dizaine de minutes, suite à cela fermez tout, retournez dans votre dossier contenant BuildTools.jar et normalement, si tout à bien fonctionner, vous devriez trouver un dossier Craftbukkit, Bukkit et Spigot, avec chacun à l’intérieur un dossier respectif “target” qui contient lui même le jar respectif.

 

 

A propos de Skywebz

Alex, 19 ans, passionné par une liste de choses bien trop longues. Créateurs de contenus vidéo-ludiques, je suis à votre disposition pour toute question ou proposition. J'aime rédiger, traduire, débattre, jouer, chanter, vivre. --- "insérer ici une citation connue pour paraître cultivé" --- --- --- --- --- Contact : [email protected]

Ceci vous intéresse peut être

Minecraft sur la Nintendo New 3DS !

Mojang annonce l'arrivée de Minecraft sur la console New 3DS de Nintendo !

Rédiger une réponse

33 Commentaires sur "Bukkit, CraftBukkit & Spigot 1.8 disponibles !"

Prévenez moi :
avatar
 
Trier par:   Commentaires récents | Commentaires ancients | Les mieux notés
Servallou
Invité

Moi ça ne marche pas, quand je mets la commande pour 64 bits, ça me met “bash: syntax error near unexpected token (‘.

Que faire ?

ArtHyro
Invité

Et ya pas pour linux Commant je suis senser fair ?

Boewen
Membre

Comment ouvrir le serveur apres sa s’il vous plait ?

J'ean louis
Invité

Comment on l’ouvre votre serveurs la ?

Michel63
Invité

Tout semble correctement installé mais quel est la ligne de commande pour lancer le serveur, d’avance merci pour la manip et l’éventuelle réponse.

wpDiscuz